Chapter 1 appendix
Getting Started with Statistical Computing
This appendix introduces you to some basic statistical concepts and graphs for one
variable. You learn about the individuals in a study (the people or things that were
measured), categorical and quantitative variables, and ways to create descriptive graphs
of the data. The distinction between variable types is critical to creating proper graphs,
as the graph type depends on the type of variable. Computers and calculators will help
you create the graphs, but you will need to determine which type is best suited to any
given variable. We begin this appendix with some basic introductory material for each
technology that will be discussed, then explain in detail how to create the graphs for each
technology.
Most statistical analyses rely heavily on statistical software. In this appendix, we
discuss the use of Excel 2016; JMP 12; Minitab Statistical Software, version 18; SPSS 24;
CrunchIt!; R; and a TI-83/-84 calculator for conducting statistical analysis. As specialized
statistical packages, JMP, Minitab, and SPSS are the most popular software choices
both in industry and in colleges and schools of business. R is an extremely powerful
statistical environment that is available for free to anyone; it relies heavily for support on
members of the academic and general statistical communities. As an all-purpose spread
sheet program, Excel provides a limited set of statistical analysis options in comparison.
However, given its pervasiveness and wide acceptance in industry and the computer
world at large, we believe it is important to give Excel proper attention. For users who
want more statistical capabilities but still prefer to work in an Excel environment, there
are a number of commercially available add-in packages (if you have JMP, WinSTAT, or
StatTools, for instance, they can be invoked from within Excel, although the last two are
not addressed in this manual).
In addition, instructions are provided for the TI-83/-84 calculators. While this kind of
tool is generally sufficient for an introductory course, most statistical analysis is beyond
the capabilities of even the best calculator. For this reason, those students seeking to con
tinue their learning of statistics should consider learning one of the specialized statistical
packages.
Even though basic guidance is provided in this and subsequent appendices, it should
be emphasized that PSLS is not bound to any of these programs. Computer output from
statistical packages is very similar, so you can feel quite comfortable using any one these
packages. In this and following chapters of the appendix, commands that are clicked or
entered are shown in bold.
File Naming Conventions
Each program has its own file extensions for saving data worksheets and output. All use
the typical interface to open and save (or “save as,” to change the file’s name) files from
the File menu.
The extensions are shown here. To access data files from the CD or website, the
naming convention is xxyy-nn.ext, where “xx” is “eg” for examples, “ex” for exercises,
or “ta” for tables; “yy” is the chapter number; and “nn” is the number of the exercise,
example, or table within the chapter. File extensions depend on the software.
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Data file extension

Output file extension

.xls or .xlsx

.xls or .xlsx
(Excel embeds output, including
graphics, into the worksheet)

Excel
.jmp

.jmpprj
Projects contain all data, reports,
and output.

.mtw
Minitab

.mpj
Projects contain both data
and output

.sav

.spv

.csv

.Rdata

(R can read many formats; comma
separated is typical)

(saves the entire
workspace)

Getting Help
If you encounter a question not answered in this material, most software platforms offer
help (both general and contextual in dialog boxes). To access all help topics, click Help
in the menu bar at the top of the screen or in the menu ribbon. For contextual help, click
Help in a dialog box. Several of these packages (Minitab, JMP, SPSS, and R) also have
tutorials available that will help you get started. Click on the Tutorial option from the
Help pull-down menu.
If you are using LaunchPad in your course, it includes videos describing how to
use most of the routines discussed here; those videos are specifically listed in each
content section. YouTube can also be a resource for “how-to” videos, but be careful:
We do not endorse any particular YouTube channel, and some of those videos may be
erroneous.
Getting Started
We assume that the reader is familiar with the basic layout and usage of Excel. As noted
earlier, Excel provides a number of standard statistical analysis procedures but is not as
comprehensive as a stand-alone statistical package. Therefore, for a few topics covered
in this book, software support is available only in a statistical package or in an enhanced
add-in version of Excel (rather than in standard Excel). Excel is the only software
platform with a dynamic worksheet (meaning it updates as data are changed that affect
formulas). All of the other programs have the capability to compute new columns, but
once computed, the data residing there are static.
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Built-in Statistical Functions and Charts
Excel has a variety of built-in statistical functions that can be used to compute common
descriptive statistics for a given set of data or to compute probabilities for well-known
statistical distributions. To find these functions, select the Formulas tab found in the main
menu. Then click More Functions, which allows you to select the category Statistical to
reveal all the statistical functions.
In addition to the built-in statistical functions, a number of graphing options are avail
able that may prove useful for data analysis (use the simplest option available—tilting
or 3-D options can distort the graphs!). The available charts are found by selecting the
Insert tab found in the main menu. A variety of graphing options can then be found in the
Charts group. A few statistical options (for example, regression fitting) can be implement
ed within the charts.
Installing the Data Analysis ToolPak Add-in
Excel’s built-in statistical functions can be useful for isolated computations. However,
attempting to do a more complete statistical analysis with a collection of “raw” functions
can be a laborious and clumsy process. Excel provides an add-in known as Analysis
ToolPak that enables you to perform a more integrative statistical analysis. This add-in
is not loaded with the standard installation of Excel. To install it, click File, Options,
Add-ins. Then, in the Manage box, choose Excel Add-ins and click Go. Select Analysis
ToolPak and finally click OK.
Invoking Data Analysis ToolPak Procedures
Once the Data Analysis ToolPak is installed, the statistical analysis routines are found by
first selecting the Data tab found on the main toolbar. You will then see the Data Analysis
command in the Analysis group. The following figure shows a blank Excel spreadsheet
with the Data Analysis command invoked, resulting in the appearance of the Data Analy
sis menu box.

Excel

Within the Data Analysis menu box, there are 19 menu choices. When you select one
of them, a dialog box specific to the statistical routine appears that asks you to indicate
where the data can be found and where the output should be displayed. To indicate where
the data for analysis reside, specify the range of cells for the data in the Input Range box.
This can be accomplished by first clicking the cursor in the Input Range box and then
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typing in the cell range; alternatively (and more easily), you can highlight the data by
clicking and dragging the mouse over the cell range. The statistical output can be placed
either in the current worksheet (placement indicated with Output Range box), in a new
worksheet tabbed with the current workbook (New Worksheet Ply option), or in an en
tirely new workbook (New Workbook option).
Upon entering JMP on either Mac or Windows, you will find the JMP home window,
which is partitioned into four sections, including recent files, and a list of open windows.
Upon opening a data set (as illustrated below), a data table will be shown in a separate
window.
JMP

Modeling Types
Variables in JMP take on a property called “modeling type,” which is just a classifica
tion for what measurements in a variable mean. For example, the chromosomal sex of
an individual (male versus female) is a different type of measurement than the age of an
individual: One is a category, whereas the other is a numeric quantity. In JMP, variables
are designated as being nominal (categories), ordinal (ordered categories), or continu
ous (numeric measurements on a scale, like age). This designation is important for JMP,
because JMP will help you produce analyses and graphical output that are appropriate for
the variable type. To change or set the modeling type of a variable, simply double-click
on the variable name, and select the data and modeling types appropriate for that variable
(as shown in the following figure).
JMP

Invoking Statistical Procedures
To produce an analysis or create a graph, users can make a sequence of selections from a
series of menus that all begin in the menu bar. In JMP, analyses and graphics are grouped
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by their context within “platforms.” For example, the Fit Y by X platform under the Ana
lyze menu allows users to test hypotheses when there is one Y variable and one X variable
(for instance, a two-group t test or a simple regression). Which type of analysis is returned
depends on the modeling types of the variables specified.
Once a platform is launched, additional options are available under the Red
Triangles in the output window. These Red Triangles are special menus that show
contextualized options—that is, analyses and options that make sense for the types
of variables specified. In this regard, JMP is said to have a “progressive” interface:
Launching a platform is the first step, and once in a platform you can produce any
number of analyses. If you are looking for a specific analysis, the Statistics Index,
which is found under the Help menu, provides a list of all available procedures, and
can even launch an example for a given analysis. If you need additional help, select the
question mark tool in the menu and click on any object in JMP to see the documenta
tion for that object.

Minitab

Upon entering Minitab, you will find the display partitioned into two windows, as seen
in the accompanying figure. The Session window is the area where all nongraphical
statistical output and Minitab commands generating statistical output (graphical and
nongraphical) are displayed. The Data window displays a spreadsheet environment
(known as a worksheet) where data can be directly entered and edited. Each column
represents a variable to be analyzed. The Project manager window—which is mini
mized when Minitab starts—keeps track of all the analyses that have been done in a
project.

Minitab
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Invoking Statistical Procedures
There are two ways to invoke procedures:
1. Type commands in the Command Line window. To do so, you must first enable the
command language:
• Click in the Session window.
• Click Editor, Show Command Line.
This will produce a “MTB>” prompt in a partition of the Session window. At this prompt,
you can then type the desired commands.
2. Make a sequence of selections beginning in the toolbar menu. For example, to create
the graph known as a boxplot, you would click Graph and then select Boxplot. In
this appendix, such a sequence of selections will be presented as Graph ➔ Boxplot.
Once you have made the necessary selections, dialog and/or option boxes will be
encountered that allow you to indicate which variable(s) will be part of the analysis,
along with other information. If further help is needed, you can click the Help button
that appears with every dialog box. Once you have entered all of the appropriate
information, click the OK button to get the desired output.

CRUNCH

Access CrunchIt! within Launchpad by clicking Resources, Content by type, then
CrunchIt!. Your instructor may have made this software available on the main “home”
Launchpad menu as well.
Upon entering CrunchIt!, you will be shown a blank data set with rows and columns
(see the accompanying figure). To enter data, click in a cell and enter a value. To change a
column name, double-click the column header and enter a new column name.
Invoking Statistical Procedures
Users can make a sequence of selections from a series of menus that all begin in the main
menu. Once you have made the necessary selections, dialog and/or option boxes will be
encountered that allow you to indicate which variable will be part of the analysis, along
with other information. If further help is needed, you can click the Help button that ap
pears in dialog boxes. Once you have entered all of the appropriate information, click the
Calculate button to get the desired output.
CrunchIt! Files
CrunchIt! provides file options from the File menu, including creating a new data set,
importing data from a file and URL, and exporting data sets to a file. CrunchIt! also pro
vides direct access to data sets from this book by selecting Load from The Practice of
Statistics in the Life Sciences.
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CRUNCH

In this section, we provide a very basic overview of using the TI-83/-84 calculator.
For more instruction, access Texas Instruments’ “getting started” tutorials at
education.ti.com ➔ Products ➔ Graphing calculators. At that point, you would
select your calculator model and then Support Resources.
After pressing the STAT button, you have three options: EDIT, CALC, and TESTS
(shown below). Selecting EDIT invokes the data-table editor, allowing you to enter data;
CALC includes options for descriptive statistics as well as regression procedures; and
TESTS includes hypothesis testing procedures.

Invoking Statistical Procedures
After entering data, statistical procedures can be selected from the CALC and TEST
sections. After you make the necessary selections, your calculator will return the results
of the tests and procedures.
R is command-line software, but some “menu” interfaces (such as R commander) can
make it easier to use—especially for beginners. To load R commander, after installing the
package, click Packages ➔ Load Package, and then select Rcmdr. This interface also
allows for an easier means of inputting data.
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Note: R is case-sensitive. If the variable name is “Color”, referring to it as “color” will
not find the variable! This is also true of all parameter names for commands.
R works from data frames (a collection of variables). There are several methods of
inputting data. For a small data set, you may want to enter the data directly from the
command line, as in the following example. This example creates a data frame called
mydat with variables x and y:
> x= c(1,2,3,4,5,6,7,8)
> y=c(10,13,8,7,9,8,4,10)
> mydat <- data.frame(x,y)
Another method evokes a spreadsheet-like input frame:
> mydata <- data.frame(num=numeric(0))
> mydata <- edit(mydata)
R

Exit the data editor by clicking on the red X at the upper-right corner.
You can also input data by reading from a file. R can read many types, including .csv
(comma-separated variable) format and .xls and .xlsx (Excel), among others. The follow
ing command to read a .csv file indicates the first row has variable names:
> mydata <- read.csv(“file.txt”,head=T)
R commands have many possible parameters that can be used to specify graphs’ titles
and other information. To obtain the full documentation for any command, click Help,
select R functions(text), and enter the name of the command in the box.
The R Video Technology Manuals: Introduction video can be helpful for users new to R.
Picturing Distributions with Graphs
Bar Graphs
Excel
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1. With pretabulated frequencies, the spreadsheet should have two columns with a
column name in the top row: One column should have the category names, and
the other column should have the total counts of each category.
2. Select all cells, including the column names.
3. Click the Insert tab and click PivotChart in the Charts group.
4. Select the desired field(s) by clicking a check mark next to the name(s).
5. A bar graph will be created automatically.
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Note: When only one column requires counting, the field name will appear in a sec
tion titled Axis Fields (Categories). This field name should also appear in the section
titled “∑ Values.” To add it there, click and hold the field name and then drag the field
from the field section into the ∑ Values section. Excel will then automatically make the
counts and create a corresponding bar graph.
6. Add a descriptive title to the graph (we want to know what it is about) by click
ing in the placeholder title. Drag the cursor to highlight the placeholder, and
type in the desired text.
7. Excel will likely add elements to the graph that are undesired. To remove them,
click to select any unwanted elements, then press the Delete key.
Pie Charts
1. Follow the steps for making a bar graph.
2. To change the created bar graph into a pie chart, click the Design tab, then
click the Change Chart Type in the Type group, then select the Pie chart
type.
Note: Alternatively, right-click on the bar graph and click the Change Chart Type
option.
Histograms
1. Data ➔ Data Analysis
2. Select Histogram in menu box and click OK.
Note: You can also click Insert, then choose Histogram from the
“Recommended Charts, All charts” list. Menu boxes there are similar to
those described in these instructions.
3. Enter the cell range containing the data into the Input Range box. If you want
Excel to automatically select the classes, leave the Bin Range box empty.
4. Place a check mark next to the Chart Output option. Click OK.
If you want to change the automatically selected classes, enter upper values for
each class into a column in the spreadsheet and input their cell range in the Bin
Range box.
5. Click in the default title (“Chart Title”). Drag the cursor to highlight it. Type
the descriptive title to replace the default.
Dotplots
Excel cannot make dotplots.
Time Plots
1. Click and drag the mouse to highlight the cell range of the data you want to use
as the basis for the time plot (include the column name if you want it to appear
as a chart label).
2. With the cell range highlighted, click the Insert tab and then click Line in the
Charts group.
3. Within the 2-D Line choices, you can choose whether to have data symbols at
the data values or not.
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Stemplots (discussed in the chapter exercises)
Excel cannot make stemplots.
For videos to help with these topics, see the Excel Video Technology Manuals on Bar
Chart, Pie Chart, Histogram, and Stemplot, Timeplot.
Bar Graphs
Using the Distribution Platform (which does not separate bars):
1. Analyze ➔ Distribution
2. Click to select the variable(s) of interest, then click Y, Columns to cast variables
into that role.
3. OK
Note: Frequency bar graphs are produced for nominal and ordinal variables, and
histograms are produced for continuous variables. If necessary, you can change the
modeling types of variables by clicking the icon next to the variable name in col
umns list in the data set.
Using Graph Builder (which properly separates bars):
1.
2.
3.
4.

Graph ➔ Graph Builder
Drag a nominal or ordinal variable of interest to the x axis.
Click the bar chart icon in the toolbar.
Give the graph a title (we need to know what it is about) by double-clicking in
the Title placeholder. Type the desired graph title.

Pie Charts
Using the Pareto Plot Platform:
1. Analyze ➔ Quality and Process ➔ Pareto Plot
2. Select the nominal or ordinal variable of interest, then click Y, Cause to cast the
variable into that role.
3. OK
4. Click the Red Triangle and select Pie Chart.
Using Graph Builder:
1.
2.
3.
4.

Graph ➔ Graph Builder
Drag a nominal or ordinal variable of interest to the x axis.
Click the pie chart in the toolbar.
Give the graph a title (we need to know what it is about) by double-clicking in
the Title placeholder. Type the desired graph title.

Histograms
1. Analyze ➔ Distribution
2. Select continuous variables of interest, then click Y, Columns to cast variables
into that role.
3. Click to check the box by Histogram Only.
4. OK
Note: This method does not allow you to give the graph a meaningful title or
change binning (intervals). Histograms can also be created using Graph Builder,
which will allow you to change the bins for the variable of interest, but those
graphs do not display a frequency y axis.

00_BAL_31901_CH01TA_001_017.indd 10

09/19/17 10:28 AM

CHAPTER 1

Appendix

TA1-11

Note: The JMP default is to display the histogram “vertically” (the data axis is on
the y axis instead of the x axis). To change this default, click the Red Triangle next to
the variable name, then click Histogram Options ➔ Vertical to turn that option off.
Dotplots
1. Help ➔ Sample Data ➔ Teaching Demonstrations ➔ Dotplot
2. At the upper left, select the column of interest.
Note: The Dot Width slider at the left allows you to change the size of the dots,
and the scaling of the x-axis.
Time Plots
Time Series Platform:
1. Analyze ➔ Modeling ➔ Time Series
2. Select the variable, and click Y, Time Series to enter that variable.
3. If a time variable is available, enter it into X, Time ID. If you do not specify a
time variable, JMP will order and label the time plot by row.
4. OK
Graph Builder (requires a time variable for X):
1.
2.
3.
4.

Graph ➔ Graph Builder
Drag the time variable to the x axis.
Drag a continuous outcome variable to the y axis.
Click the line chart (next to the bar chart icon) in the toolbar.

Stemplots
1. Analyze ➔ Distribution
2. Select continuous variables of interest, then click Y, Columns to cast variables
into that role.
3. OK
4. Click the Red Triangle next to a variable’s name and select Stem and Leaf.
For videos to help with these topics, see the JMP Video Technology Manuals on Bar
Chart, Pie Chart, Histogram, and Stemplot, Timeplot.
Bar Graphs
Minitab

1. Graph ➔ Bar Chart
2. If the frequencies have been pretabulated, select Values from a table from the
Bars represent menu.
If the frequencies have not been tabulated, select Counts of unique values
from the Bars represent menu. Select Simple for the type of bar graph.
3. OK
4. For pretabulated frequencies, click-in the data column into the Graph
variables box and click-in the column that has the names of the categories
into the Categorical variables box.
If the frequencies have not been pretabulated, click-in the column that has
data on the categorical values that need to be counted into the Categorical
variables box.
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5. To give the chart a title, click Labels. Enter the title in the appropriate box and
then click OK.
6. OK
Pie Charts
1. Graph ➔ Pie Chart
If the frequencies have been pretabulated:
2. Select the Chart values from a table option.
3. Click-in the column that has the names of the categories into the Categorical
variables box and the frequency column into the Summary variables box.
If the frequencies have not been pretabulated:
2. Select the Counts of unique values option.
3. Click-in the column that has data on the categorical names that need to be
counted into the Categorical variables box.
4. Click Labels. Enter a descriptive title for the chart in the appropriate box. If you
want the pie slices to be labeled by categorical names and have percents reported,
click the Slice Labels tab and place check marks next to the desired labels.
Histograms
Graph ➔ Histogram
Select Simple for the type of histogram.
OK
Click-in the data column into the Graph variables box.
To give the chart a title, click Labels. Enter the title in the appropriate box and
then click OK.
6. OK
7. To change the automatically selected classes (bins), double-click on the hori
zontal axis to make the Edit Scale box appear. Click the Binning tab and then
choose the Midpoint/Cutpoint positions option found in the Interval Definition
section. Depending on whether you choose the Interval type as “Midpoint” or
“Cutpoint,” you would then give the desired values of the midpoints (that is, the
middle values of the classes) or the cutpoints (that is, lower and upper values of
the classes). It is not necessary to enter all the values; Minitab will extend your
bins to the entire scale of values when you click OK.
1.
2.
3.
4.
5.

Stemplots
1. Graph ➔ Stem-and-Leaf
2. Click-in the data column into the Graph variables box.
3. OK
Dotplots
1. Graph ➔ Dotplot
2. For a single distribution (sample), click the icon for One Y, simple, then OK.
3. Select and enter the variable to graph into the Graph variable(s) box.
4. OK
Note: Titles can be added using Labels before clicking OK.
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Time Plots
1.
2.
3.
4.

Graph ➔ Time Series Plot
Select Simple for the type of time series plot.
OK
Click-in the data column into the Series box.
Note: By default, Minitab will label the time periods as “1,” “2,” “3,” … If you
want to label the time periods by year, click the Time/Scale button, select the
Calendar option, and select the desired time periods (for example, “Year”) from
the adjacent menu and enter a starting value. Clicking OK returns to the main
dialog, and clicking OK again produces the plot.

For videos to help with these topics, see the Minitab Video Technology Manuals on Bar
Chart, Pie Chart, Histogram, and Stemplot, Timeplot.
Note: If you are creating several graphs in a sequence using Chart Builder, click Reset
at the bottom of the dialog box between each one.
Bar Charts
1. Graphs ➔ Chart Builder
2. Select the Bar Chart graph type from the Gallery and drag it to the graph area.
3. Select the categorical variable of interest on the left, and drag it to the X-axis?
box. If data have been summarized (that is, if you have counts for each category
instead of raw data), select the frequency variable and drag it to the Y-axis? box.
4. Click the Titles/Footnotes tab. Type an appropriate title into the Content box.
5. Apply ➔ OK
Pie Charts
1. Graphs ➔ Chart Builder
2. Select the Pie/Polar graph type from the Gallery and drag it to the graph area.
3. Select the categorical variable of interest on the left, and drag it to the Slice by
box. If data have been summarized (that is, if you have counts for each category
instead of raw data), select the frequency variable and drag it to the Angle
variable? box.
4. Click the Titles/Footnotes tab. Type an appropriate title into the Content box.
5. Apply ➔ OK
Histograms
1. Graphs ➔ Chart Builder
2. Select the Histogram graph type from the Gallery and drag it to the graph area.
3. Select the categorical variable of interest on the left, and drag it to the X-axis?
box.
4. Click the Titles/Footnotes tab. Type an appropriate title into the Content box.
5. Apply ➔ OK
6. To change the binning (bar scaling), double-click in the graph for the Chart Editor,
then click in a bar of the graph for Properties. Select the Binning tab. Move the
radio button to Custom and enter either a number of bars (bins) or a bin width,
using the appropriate radio button. Click Apply. To change the maximum or mini
mum x value, click X in the graph tool bar, and then click the Scale tab. Uncheck
the box under Auto next to the value you want to change and enter the new value.
Click Apply ➔ Close to apply the changes and close the chart editor.
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Dotplots
1. Graphs ➔ Chart Builder
2. In the graph type box at lower left, select Scatter/Dot. Drag the “Simple Dot
Plot” icon at lower left of the displayed graphs to the x-axis.
3. Drag the variable to the x-axis.
4. If desired, click the Titles/Footnotes tab to label your graph.
5. OK
Time Plots
With Sequence Charts:
1. Analyze ➔ Forecasting ➔ Sequence Chart
2. Select the variable of interest on the left, then click the right arrow next to
Variables to move the variable to that section.
3. If you have a variable identifying time, select it and click the right arrow next to
Time Axis Labels.
4. OK
With Scatter/Dot (requires a “time” variable):
1.
2.
3.
4.
5.
6.
7.

Graphs ➔ Chart Builder
Select the Simple Scatter graph type from the Gallery and drag it to the graph area.
Select the outcome variable and drag it to the Y-Axis? box.
Select the time variable and drag it to the X-Axis? box.
Click the Titles/Footnotes tab. Type an appropriate title into the Content box.
Apply ➔ OK
Double-click the scatterplot in the output window to open the editor.

8. In the toolbar, select the Interpolation Line button
9. Close the editor to finalize the graph.

to connect the points.

Stemplots
1. Analyze ➔ Descriptive Statistics ➔ Explore
2. Select the variable of interest on the left, then click the right arrow next to
Dependent List to move the variable to that section.
3. OK
Note: This procedure also produces a box plot and descriptive statistics by
default.
For videos to help with these topics, see the SPSS Video Technology Manuals on Bar
Chart, Pie Chart, Histogram, and Stemplot, Timeplot.

CRUNCH

Bar Graphs
With summarized data:
1.
2.
3.
4.
5.
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Graphics ➔ Bar Chart With Summarized Data
For Labels, select the column identifying the groups.
For Heights, select the frequency variable.
Add a title and x and y -axis labels, if desired.
Calculate
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With raw data:
1. Graphics ➔ Bar Chart With Raw Data
2. For Sample, select the column of interest; to avoid many “short” bars, you can
enter a value in Cutoff that will gather together all categories with frequencies
less than the specified value into an “Other” category.
3. Add a title and x- and y-axis labels, if desired.
4. Calculate
Pie Charts
1.
2.
3.
4.
5.
6.

With summarized data:
Graphics ➔ Pie Chart With Summarized Data
For Labels, select the column identifying the categorical variable.
For Sizes, select the frequency variable.
Add a title, if desired.
Calculate

With raw data:
1. Graphics ➔ Pie Chart With Raw Data
2. For Sample, select the column of interest; to avoid many small slices, you can
enter a value in Cutoff that will gather together all categories with frequencies
less than the specified value into an “Other” category.
3. Add a title and x- and y -axis labels if desired.
4. Calculate
Histograms
1.
2.
3.
4.
5.

Graphics ➔ Histogram
For Sample, select the column of interest.
If desired, specify either the number of bins or the bin width and start point.
Add a title and axis labels.
Calculate

Dotplots
1. Graphics ➔ Dot Plot
2. Use the drop-down to select the column with your data. If desired, enter a title
and axis label.
3. Calculate
Time Plots (must have a time or index variable)
1. Graphics ➔ Scatter Plot
2. For X, enter a time variable; this variable must be numeric, such as the day, the
year, or an index (1, 2, …, n).
3. For Y, select the variable of interest.
4. In the Parameters section, change Points to Lines or Both.
5. Calculate
Stemplots
1.
2.
3.
4.

Graphics ➔ Stem and Leaf
For Sample, select the column of interest.
If desired, enter a title.
Calculate

For videos to help with these topics, see the CrunchIt! Help Videos on Pictures for
Categorical Data and Pictures for Quantitative Data.
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TI calculators try to graph everything they can at the same time. For that reason, before
creating any statistical graph/plot, you should confirm that no functions are entered
on the Y= screen; if so, use CLEAR to erase those functions. Also, make sure only one
STAT PLOT is “On” at a time; use STAT PLOTS option 4:PlotsOff to turn them all off.
Because graphs created with TI calculators are unlabeled, they can be used only as
a guide. To see the graph contents and have an aid to copying them onto paper, use
TRACE and the left and right arrows to move through the graph.
Bar Graphs
1.
2.
3.
4.
5.
6.
7.
8.

Press STAT ENTER to select Edit.
In L1, enter sequential values (1, 2, 3, …) up to as many categories you have.
Enter the values associated with each category in L2.
Press WINDOW, then set the Xmin and Xmax to match the values in L1, and ad
just Ymin and Ymax to be an appropriate range for your frequency (Y) variable.
Press 2nd Y= = STAT PLOT. Select Plot 1 by pressing ENTER .
Turn the plot “On” if needed by using the
and pressing ENTER to move the
highlight. Select the histogram
.
Select L1 for Xlist, and L2 for Freq.
Press GRAPH .

Pie Charts
Pie charts are not available on TI-83/-84 calculators.
Histograms
1. Press 2nd Y= = STAT PLOT, and select a plot (press ENTER to select Plot 1).
Select the histogram.
2. Turn the plot “On” if needed by using the
and pressing ENTER to move the
highlight. Select the histogram
.
3. Enter the name of the list that contains the data by pressing 2nd 1 = [L1], 2nd
2 = [L2], ….
4. Get an initial histogram by pressing ZOOM 9 .
5. Adjust the windowing (if needed) using WINDOW . Reset Xmin, Xmax, Xscl (the
bar width), and Ymax as needed.
9. Press GRAPH .
Dotplots
TI calculators cannot make dotplots.
Time Plots
Press STAT and select Edit to enter the list editor.
In L1, enter time values (or an index from 1 to n).
In L2, enter data for the outcome variable.
Press 2nd Y= = STAT PLOT (2nd, then Y= button), and select the connected
scatterplot,
.
5. Select L1 for Xlist, and L2 for Ylist.
6. Press ZOOM 9 .
1.
2.
3.
4.

Stemplots
Stemplots are not available on TI calculators.
For videos to help with these topics, see the TI Video Technology Manuals on Histo
gram and Timeplot.
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Here, we presume the data are in a data frame named “mydat.” A categorical variable is
named “catvar,” a frequency variable is named “frq,” and a numeric variable is named
“numvar.”
Bar Graphs
A basic bar graph with raw data can be created using the command
> barplot(table(mydat$catvar))
If data are already summarized, use the command
> barplot(mydat$frq, names.arg=mydat$catvar)
Pie Charts
A pie chart with raw data can be created with the command
> pie(table(mydat$catvar))
If data are already summarized, modify the command to
> pie(mydat$frq, names=mydat$catvar)
Histograms
A basic histogram can be created using the command
> hist(mydat$numvar)
To set your own bins (bins start and end at the specified values, which must span
the whole range of the variable), modify the command to
> hist(mydat$numvar, breaks=c(5,10,15,20,25))
Dotplots
The R command for a dotplot is “stripchart.” The stack parameter indicates how
observations with the same value should be treated. See an example below.
> stripchart(mydat$numvar,method=”stack”)
Time Plots
A time series plot using an index or other variable for time can be done as a con
nected scatterplot. Use type=“b” to have both points and lines, or type=“l” to
simply have connect lines.
> plot(mydat$x,mydat$numvar, type=“b”)
Stemplots
> stem(mydat$numvar)
For videos to help with these topics, see the R Video Technology Manuals on Bar
Chart, Pie Chart, Histogram, and Stemplot, Timeplot.
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